Kernel Functions for Drivers DB_BASE(9F)
NAME
DB_BASE, DB_LIM, DB_REF, DB_TYPE - Data block access macros
SYNOPSIS
#include
#include
uchar_t *DB_BASE(mblk_t *mp);
uchar_t *DB_LIM(mblk_t *mp);
uchar_t DB_TYPE(mblk_t *mp);
uchar_t DB_REF(mblk_t *mp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).PARAMETERS
mp Message block to be accessed.DESCRIPTION
These macros provide compact access to public members of the datab(9S) structure associated with the specified message block. In all cases, these macros are equivalent to directly accessing the underlying fields of the datab(9S) associated with the specified message block. Specifically:DB_BASE(mp) is equivalent to mp->b_datap->db_base.
DB_LIM(mp) is equivalent to mp->b_datap->db_lim.
DB_TYPE(mp) is equivalent to mp->b_datap->db_type.
DB_REF(mp) is equivalent to mp->b_datap->db_ref.
CONTEXT
SunOS 5.11 Last change: 9 June 2004 1
Kernel Functions for Drivers DB_BASE(9F)
These functions can be called from user, kernel or interrupt context.SEE ALSO
msgb(9S), datab(9S) STREAMS Programming GuideSunOS 5.11 Last change: 9 June 2004 2