Manual Pages for UNIX Darwin command on man suibyte
MyWebUniversity

Manual Pages for UNIX Darwin command on man suibyte

STORE(9) BSD Kernel Developer's Manual STORE(9)

NAME

ssttoorree, ssuubbyyttee, ssuuiibbyyttee, ssuuwwoorrdd, ssuuiiwwoorrdd, ssuulloonngg, ssuuuulloonngg - store data to

user-space

SYNOPSIS

##iinncclluuddee <>

##iinncclluuddee <>

##iinncclluuddee <>

##iinncclluuddee <>

int ssuubbyyttee(useraddrt addr, int byte); int ssuuiibbyyttee(useraddrt addr, int byte); int ssuuwwoorrdd(useraddrt addr, int word); int ssuuiiwwoorrdd(useraddrt addr, int word); int ssuulloonngg(useraddrt addr, int64t longword); int ssuuuulloonngg(useraddrt addr, uint64t longword);

DESCRIPTION

The ssttoorree functions are designed to copy small amounts of data to user-

space. The ssttoorree routines provide the following functionality:

ssuubbyyttee() Stores a byte of data to the user-space address addr.

ssuuiibbyyttee() Stores a byte of data to the user-space address addr. This

function is safe to call during an interrupt context.

ssuuwwoorrdd() Stores a word of data to the user-space address addr.

ssuuiiwwoorrdd() Stores a word of data to the user-space address addr. This

function is safe to call during an interrupt context.

ssuulloonngg() Stores a long word of data to the user-space address addr.

ssuuuulloonngg() Stores a unsigned long word of data to the user-space address

addr.

RETURN VALUES

The ssttoorree functions return 0 on success or -1 on failure.

SEE ALSO

copy(9), fetch(9) BSD December 16, 2004 BSD




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™