Manual Pages for UNIX Darwin command on man stab
MyWebUniversity

Manual Pages for UNIX Darwin command on man stab

STAB(5) BSD File Formats Manual STAB(5)

NAME

ssttaabb - symbol table types

SYNOPSIS

##iinncclluuddee <>

DESCRIPTION

The file defines some of the symbol table ntype field values

for Mach-O a.out files. These are the types for permanent symbols (i.e.

not local labels, etc.) used by the old debugger sdb and the Berkeley Pascal compiler pc(1). Symbol table entries can be produced by the

.stabs assembler directive. This allows one to specify a double-quote

delimited name, a symbol type, one char and one short of information about the symbol, and an unsigned long (usually an address). To avoid

having to produce an explicit label for the address field, the .stabd

directive can be used to implicitly address the current location. If no

name is needed, symbol table entries can be generated using the .stabn

directive. The loader promises to preserve the order of symbol table

entries produced by .stab directives. As described in comments in o/nlist.h> an element of the symbol table consists of the following structure: /* * Format of a symbol table entry. */ struct nlist { union {

char *nname; /* for use when in-core */

long nstrx; /* index into file string table */ } nun; unsigned char ntype; /* type flag */ char nsect; /* section number or NOSECT */ short ndesc; /* see struct desc, below */ unsigned nvalue; /* address or offset or line */ }; The low bits of the ntype field are used for the symbol type, according to the following masks, defined in . A symbol can be of none these types by having none of these bits set. /* * Simple values for ntype. */

#define NUNDF 0x0 /* undefined */

#define NABS 0x2 /* absolute */

#define NSECT 0xe /* defined in section number nsect */

#define NEXT 01 /* external bit, or'ed in */

The nvalue field of a symbol is relocated by the linker, ld(1) as an address within the appropriate section for NSECT types based on the. Nvalue fields of symbols not in any segment are unchanged by the linker. In addition, the linker will discard certain symbols, according to rules of its own, unless the ntype field has one of the following bits set: /* * Other permanent symbol table entries have some of the NSTAB bits set.

* These are given in

*/

#define NSTAB 0xe0 /* if any of these bits set, don't discard */

This allows up to 112 (7 * 16) symbol types, split between the various symbol types. Some of these have already been claimed. The old symbolic debugger, sdb, uses the following ntype values:

#define NGSYM 0x20 /* global symbol: name,,NOSECT,type,0 */

#define NFNAME 0x22 /* procedure name (f77 kludge): name,,NOSECT */

#define NFUN 0x24 /* procedure: name,,nsect,linenumber,address */

#define NSTSYM 0x26 /* static symbol: name,,nsect,type,address */

#define NLCSYM 0x28 /* .lcomm symbol: name,,nsect,type,address */

#define NBNSYM 0x2e /* begin nsect sym: 0,,nsect,0,address */

#define NRSYM 0x40 /* register sym: name,,NOSECT,type,register */

#define NSLINE 0x44 /* src line: 0,,nsect,linenumber,address */

#define NENSYM 0x4e /* end nsect sym: 0,,nsect,0,address */

#define NSSYM 0x60 /* structure elt: name,,NOSECT,type,structoffset */

#define NSO 0x64 /* source file name: name,,nsect,0,address */

#define NLSYM 0x80 /* local sym: name,,NOSECT,type,offset */

#define NBINCL 0x82 /* include file beginning: name,,NOSECT,0,sum */

#define NSOL 0x84 /* #included file name: name,,nsect,0,address */

#define NPSYM 0xa0 /* parameter: name,,NOSECT,type,offset */

#define NEINCL 0xa2 /* include file end: name,,NOSECT,0,0 */

#define NENTRY 0xa4 /* alternate entry: name,,nsect,linenumber,address */

#define NLBRAC 0xc0 /* left bracket: 0,,NOSECT,nesting level,address */

#define NEXCL 0xc2 /* deleted include file: name,,NOSECT,0,sum */

#define NRBRAC 0xe0 /* right bracket: 0,,NOSECT,nesting level,address */

#define NBCOMM 0xe2 /* begin common: name,,NOSECT,0,0 */

#define NECOMM 0xe4 /* end common: name,,nsect,0,0 */

#define NECOML 0xe8 /* end common (local name): 0,,nsect,0,address */

#define NLENG 0xfe /* second stab entry with length information */

where the comments give sdb conventional use for .stab s and the nname,

nsect, ndesc, and nvalue fields of the given ntype. Sdb uses the ndesc field to hold a type specifier in the form used by the Portable C Compiler, cc(1); see the header file pcc.h for details on the format of these type values. The Berkeley Pascal compiler, pc(1), uses the following ntype value:

#define NPC 0x30 /* global pascal symbol: name,,NOSECT,subtype,line */

and uses the following subtypes to do type checking across separately compiled files: 1 source file name 2 included file name 3 global label 4 global constant 5 global type 6 global variable 7 global function 8 global procedure 9 external function 10 external procedure 11 library variable 12 library routine

SEE ALSO

as(1), ld(1), dbx(1), Mach-O(5)

BUGS

More basic types are needed. HISTORY The ssttaabb file appeared in 4.0BSD. Darwin November 16, 2001 Darwin




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™