Manual Pages for UNIX Darwin command on man ip
MyWebUniversity

Manual Pages for UNIX Darwin command on man ip

IP(4) BSD Kernel Interfaces Manual IP(4)

NAME

iipp - Internet Protocol

SYNOPSIS

##iinncclluuddee <>

##iinncclluuddee <>

int ssoocckkeett(AFINET, SOCKRAW, proto);

DESCRIPTION

IP is the transport layer protocol used by the Internet protocol family.

Options may be set at the IP level when using higher-level protocols that

are based on IP (such as TCP and UDP). It may also be accessed through a

``raw socket'' when developing new protocols, or special-purpose applica-

tions.

There are several IP-level setsockopt(2) /getsockopt(2) options.

IPOPTIONS may be used to provide IP options to be transmitted in the IP

header of each outgoing packet or to examine the header options on incom-

ing packets. IP options may be used with any socket type in the Internet family. The format of IP options to be sent is that specified by the IP

protocol specification (RFC-791), with one exception: the list of

addresses for Source Route options must include the first-hop gateway at

the beginning of the list of gateways. The first-hop gateway address

will be extracted from the option list and the size adjusted accordingly

before use. To disable previously specified options, use a zero-length

buffer:

setsockopt(s, IPPROTOIP, IPOPTIONS, NULL, 0);

IPTOS and IPTTL may be used to set the type-of-service and time-to-live

fields in the IP header for SOCKSTREAM and SOCKDGRAM sockets. For exam-

ple, int tos = IPTOSLOWDELAY; /* see */ setsockopt(s, IPPROTOIP, IPTOS, &tos, sizeof(tos)); int ttl = 60; /* max = 255 */ setsockopt(s, IPPROTOIP, IPTTL, &ttl, sizeof(ttl)); If the IPRECVDSTADDR option is enabled on a SOCKDGRAM socket, the recvmsg call will return the destination IP address for a UDP datagram. The msgcontrol field in the msghdr structure points to a buffer that contains a cmsghdr structure followed by the IP address. The cmsghdr fields have the following values: cmsglen = sizeof(struct inaddr) cmsglevel = IPPROTOIP cmsgtype = IPRECVDSTADDR Multicast Options IP multicasting is supported only on AFINET sockets of type SOCKDGRAM and SOCKRAW, and only on networks where the interface driver supports multicasting.

The IPMULTICASTTTL option changes the time-to-live (TTL) for outgoing

multicast datagrams in order to control the scope of the multicasts: uchar ttl; /* range: 0 to 255, default = 1 */ setsockopt(s, IPPROTOIP, IPMULTICASTTTL, &ttl, sizeof(ttl)); Datagrams with a TTL of 1 are not forwarded beyond the local network.

Multicast datagrams with a TTL of 0 will not be transmitted on any net-

work, but may be delivered locally if the sending host belongs to the destination group and if multicast loopback has not been disabled on the sending socket (see below). Multicast datagrams with TTL greater than 1 may be forwarded to other networks if a multicast router is attached to the local network.

For hosts with multiple interfaces, each multicast transmission is sent

from the primary network interface. The IPMULTICASTIF option overrides the default for subsequent transmissions from a given socket: struct inaddr addr; setsockopt(s, IPPROTOIP, IPMULTICASTIF, &addr, sizeof(addr)); where "addr" is the local IP address of the desired interface or INADDRANY to specify the default interface. An interface's local IP address and multicast capability can be obtained via the SIOCGIFCONF and SIOCGIFFLAGS ioctls. Normal applications should not need to use this option. If a multicast datagram is sent to a group to which the sending host itself belongs (on the outgoing interface), a copy of the datagram is, by default, looped back by the IP layer for local delivery. The IPMULTICASTLOOP option gives the sender explicit control over whether or not subsequent datagrams are looped back: uchar loop; /* 0 = disable, 1 = enable (default) */ setsockopt(s, IPPROTOIP, IPMULTICASTLOOP, &loop, sizeof(loop)); This option improves performance for applications that may have no more

than one instance on a single host (such as a router demon), by eliminat-

ing the overhead of receiving their own transmissions. It should gener-

ally not be used by applications for which there may be more than one instance on a single host (such as a conferencing program) or for which the sender does not belong to the destination group (such as a time querying program). A multicast datagram sent with an initial TTL greater than 1 may be delivered to the sending host on a different interface from that on which it was sent, if the host belongs to the destination group on that other interface. The loopback control option has no effect on such delivery. A host must become a member of a multicast group before it can receive datagrams sent to the group. To join a multicast group, use the IPADDMEMBERSHIP option:

struct ipmreq mreq;

setsockopt(s, IPPROTOIP, IPADDMEMBERSHIP, &mreq, sizeof(mreq)); where mreq is the following structure:

struct ipmreq {

struct inaddr imrmultiaddr; /* multicast group to join */ struct inaddr imrinterface; /* interface to join on */ }

imrinterface should be INADDRANY to choose the default multicast inter-

face, or the IP address of a particular multicast-capable interface if

the host is multihomed. Membership is associated with a single inter-

face; programs running on multihomed hosts may need to join the same group on more than one interface. Up to IPMAXMEMBERSHIPS (currently

20) memberships may be added on a single socket.

To drop a membership, use:

struct ipmreq mreq;

setsockopt(s, IPPROTOIP, IPDROPMEMBERSHIP, &mreq, sizeof(mreq));

where mreq contains the same values as used to add the membership. Mem-

berships are dropped when the socket is closed or the process exits.

RRaaww IIPP SSoocckkeettss Raw IP sockets are connectionless, and are normally used with the sendto and recvfrom calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the read(2) or recv(2) and write(2) or send(2) system calls may be used). If proto is 0, the default protocol IPPROTORAW is used for outgoing packets, and only incoming packets destined for that protocol are

received. If proto is non-zero, that protocol number will be used on

outgoing packets and to filter incoming packets. Outgoing packets automatically have an IP header prepended to them (based on the destination address and the protocol number the socket is created with), unless the IPHDRINCL option has been set. Incoming packets are received with IP header and options intact. IPHDRINCL indicates the complete IP header is included with the data and may be used only with the SOCKRAW type.

#include

int hincl = 1; /* 1 = on, 0 = off */ setsockopt(s, IPPROTOIP, IPHDRINCL, &hincl, sizeof(hincl)); Unlike previous BSD releases, the program must set all the fields of the IP header, including the following:

ip->ipv = IPVERSION;

ip->iphl = hlen >> 2;

ip->ipid = 0; /* 0 means kernel set appropriate value */

ip->ipoff = htons(offset);

ip->iplen = htons(len);

Additionally note that starting with OpenBSD 2.1 the ipoff and iplen

fields are in network byte order. If the header source address is set to INADDRANY, the kernel will choose an appropriate address. DIAGNOSTICS A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destination address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination

address is specified, and the socket hasn't been con-

nected; [ENOBUFS] when the system runs out of memory for an internal data structure;

[EADDRNOTAVAIL] when an attempt is made to create a socket with a net-

work address for which no network interface exists. [EACESS] when an attempt is made to create a raw IP socket by a

non-privileged process.

The following errors specific to IP may occur when setting or getting IP options: [EINVAL] An unknown socket option name was given. [EINVAL] The IP option field was improperly formed; an option field was shorter than the minimum value or longer than the option buffer provided.

SEE ALSO

getsockopt(2), send(2), recv(2), intro(4), icmp(4), inet(4) HISTORY

The iipp protocol appeared in 4.2BSD.

4.2 Berkeley Distribution November 30, 1993 4.2 Berkeley Distribution




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™