Manual Pages for UNIX Darwin command on man fstab
MyWebUniversity

Manual Pages for UNIX Darwin command on man fstab

FSTAB(5) BSD File Formats Manual FSTAB(5)

NAME

ffssttaabb - static information about the filesystems

SYNOPSIS

##iinncclluuddee <>

DESCRIPTION

The file ffssttaabb contains descriptive information about the various file systems. ffssttaabb is only read by programs, and not written; it is the duty of the system administrator to properly create and maintain this file. Each filesystem is described on a separate line; fields on each line are separated by tabs or spaces. The order of records in ffssttaabb is important

because diskarbitrationd(8), fsck(8), mount(8), and umount(8) sequen-

tially iterate through ffssttaabb doing their thing. The first field, (fsspec), describes the block special device, the local filesystem, or the remote filesystem to be mounted. The diskarbitrationd program supports the identification of a local filesystem uniquely by its UUID or by its volume name, irrespective of hardware configuration and of hardware parallelism, using the constructs ``UUID'' and ``LABEL''.

The second field, (fsfile), describes the mount point for the filesys-

tem. For swap partitions, this field should be specified as ``none''. The third field, (fsvfstype), describes the type of the filesystem. The system currently supports these types of filesystems: ufs a local UNIX filesystem nfs a Sun Microsystems compatible ``Network File System'' swap a disk partition to be used for swapping msdos a DOS compatible filesystem

cd9660 a CD-ROM filesystem (as per ISO 9660)

procfs a file system for accessing process data kernfs a file system for accessing kernel parameters fdesc an implementation of /dev/fd union a translucent filesystem The fourth field, (fsmntops), describes the mount options associated with the filesystem. It is formatted as a comma separated list of options. It contains at least the type of mount (see fstype below) plus any additional options appropriate to the filesystem type. The option ``auto'' can be used in the ``noauto'' form to cause a file

system not to be mounted automatically (with ``mount -a'', or system boot

time). The type of the mount is extracted from the fsmntops field and stored separately in the fstype field (it is not deleted from the fsmntops field). If fstype is ``rw'' or ``ro'' then the filesystem whose name is

given in the fsfile field is normally mounted read-write or read-only on

the specified special file. If fstype is ``sw'' then the special file is made available as a piece of swap space by the swapon(8) command at the end of the system reboot procedure. The fields other than fsspec and fstype are unused. If fstype is specified as ``xx'' the entry is ignored. This is useful to show disk partitions which are currently unused. The fifth field, (fsfreq), is used for these filesystems by the dump(8) command to determine which filesystems need to be dumped. If the fifth field is not present, a value of zero is returned and dump will assume that the filesystem does not need to be dumped. The sixth field, (fspassno), is used by the fsck(8) program to determine the order in which filesystem checks are done at reboot time. The root

filesystem should be specified with a fspassno of 1, and other filesys-

tems should have a fspassno of 2. Filesystems within a drive will be checked sequentially, but filesystems on different drives will be checked at the same time to utilize parallelism available in the hardware. If the sixth field is not present or zero, a value of zero is returned and fsck will assume that the filesystem does not need to be checked.

#define FSTABRW "rw" /* read-write device */

#define FSTABRO "ro" /* read-only device */

#define FSTABSW "sw" /* swap device */

#define FSTABXX "xx" /* ignore totally */

struct fstab {

char *fsspec; /* block special device name */ char *fsfile; /* filesystem path prefix */ char *fsvfstype; /* type of filesystem */ char *fsmntops; /* comma separated mount options */ char *fstype; /* rw, ro, sw, or xx */ int fsfreq; /* dump frequency, in days */ int fspassno; /* pass number on parallel fsck */ };

The proper way to read records from fstab is to use the routines

getfsent(3), getfsspec(3), getfstype(3), and getfsfile(3). EEXXAAMMPPLLEESS

UUID=DF000C7E-AE0C-3B15-B730-DFD2EF15CB91 /export ufs ro

UUID=FAB060E9-79F7-33FF-BE85-E1D3ABD3EDEA none hfs rw,noauto

LABEL=The\040Volume\040Name\040Is\040This none msdos ro FILES

/etc/fstab The file ffssttaabb resides in /etc.

SEE ALSO

getfsent(3), diskarbitrationd(8) HISTORY The ffssttaabb file format appeared in 4.0BSD. Darwin March 28, 2002 Darwin




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™