Manual Pages for UNIX Darwin command on man fs
MyWebUniversity

Manual Pages for UNIX Darwin command on man fs

FS(5) BSD File Formats Manual FS(5)

NAME

ffss, iinnooddee - format of file system volume

SYNOPSIS

##iinncclluuddee <>

##iinncclluuddee <>

##iinncclluuddee <>

DESCRIPTION

The files and declare several structures, defined vari-

ables and macros which are used to create and manage the underlying for-

mat of file system objects on random access devices (disks). The block size and number of blocks which comprise a file system are

parameters of the file system. Sectors beginning at BBLOCK and continu-

ing for BBSIZE are used for a disklabel and for some hardware primary and secondary bootstrapping programs.

The actual file system begins at sector SBLOCK with the super-block that

is of size SBSIZE. The following structure described the super-block and

is from the file :

#define FSMAGIC 0x011954

struct fs {

struct fs *fslink; /* linked list of file systems */

struct fs *fsrlink; /* used for incore super blocks */

daddrt fssblkno; /* addr of super-block in filesys */

daddrt fscblkno; /* offset of cyl-block in filesys */

daddrt fsiblkno; /* offset of inode-blocks in filesys */

daddrt fsdblkno; /* offset of first data after cg */

long fscgoffset; /* cylinder group offset in cylinder */

long fscgmask; /* used to calc mod fsntrak */

timet fstime; /* last time written */

long fssize; /* number of blocks in fs */

long fsdsize; /* number of data blocks in fs */

long fsncg; /* number of cylinder groups */

long fsbsize; /* size of basic blocks in fs */

long fsfsize; /* size of frag blocks in fs */

long fsfrag; /* number of frags in a block in fs */

/* these are configuration parameters */

long fsminfree; /* minimum percentage of free blocks */

long fsrotdelay; /* num of ms for optimal next block */

long fsrps; /* disk revolutions per second */

/* these fields can be computed from the others */

long fsbmask; /* ``blkoff'' calc of blk offsets */

long fsfmask; /* ``fragoff'' calc of frag offsets */

long fsbshift; /* ``lblkno'' calc of logical blkno */

long fsfshift; /* ``numfrags'' calc number of frags */

/* these are configuration parameters */

long fsmaxcontig; /* max number of contiguous blks */

long fsmaxbpg; /* max number of blks per cyl group */

/* these fields can be computed from the others */

long fsfragshift; /* block to frag shift */

long fsfsbtodb; /* fsbtodb and dbtofsb shift constant */

long fssbsize; /* actual size of super block */

long fscsmask; /* csum block offset */

long fscsshift; /* csum block number */

long fsnindir; /* value of NINDIR */

long fsinopb; /* value of INOPB */

long fsnspf; /* value of NSPF */

/* yet another configuration parameter */

long fsoptim; /* optimization preference, see below */

/* these fields are derived from the hardware */

long fsnpsect; /* # sectors/track including spares */

long fsinterleave; /* hardware sector interleave */

long fstrackskew; /* sector 0 skew, per track */

long fsheadswitch; /* head switch time, usec */

long fstrkseek; /* track-to-track seek, usec */

/* sizes determined by number of cylinder groups and their sizes */

daddrt fscsaddr; /* blk addr of cyl grp summary area */

long fscssize; /* size of cyl grp summary area */

long fscgsize; /* cylinder group size */

/* these fields are derived from the hardware */

long fsntrak; /* tracks per cylinder */

long fsnsect; /* sectors per track */

long fsspc; /* sectors per cylinder */

/* this comes from the disk driver partitioning */

long fsncyl; /* cylinders in file system */

/* these fields can be computed from the others */

long fscpg; /* cylinders per group */

long fsipg; /* inodes per group */

long fsfpg; /* blocks per group * fsfrag */

/* this data must be re-computed after crashes */

struct csum fscstotal; /* cylinder summary information */

/* these fields are cleared at mount time */

char fsfmod; /* super block modified flag */

char fsclean; /* file system is clean flag */

char fsronly; /* mounted read-only flag */

char fsflags; /* currently unused flag */

char fsfsmnt[MAXMNTLEN]; /* name mounted on */

/* these fields retain the current block allocation info */

long fscgrotor; /* last cg searched */

struct csum *fscsp[MAXCSBUFS]; /* list of fscs info buffers */

long fscpc; /* cyl per cycle in postbl */

short fsopostbl[16][8]; /* old rotation block list head */

long fssparecon[56]; /* reserved for future constants */

quad fsqbmask; /* ~fsbmask - for use with quad size */

quad fsqfmask; /* ~fsfmask - for use with quad size */

long fspostblformat; /* format of positional layout tables */

long fsnrpos; /* number of rotational positions */

long fspostbloff; /* (short) rotation block list head */

long fsrotbloff; /* (uchar) blocks for each rotation */

long fsmagic; /* magic number */

uchar fsspace[1]; /* list of blocks for each rotation */

/* actually longer */ };

Each disk drive contains some number of file systems. A file system con-

sists of a number of cylinder groups. Each cylinder group has inodes and data.

A file system is described by its super-block, which in turn describes

the cylinder groups. The super-block is critical data and is replicated

in each cylinder group to protect against catastrophic loss. This is

done at file system creation time and the critical super-block data does

not change, so the copies need not be referenced further unless disaster strikes. Addresses stored in inodes are capable of addressing fragments of `blocks'. File system blocks of at most size MAXBSIZE can be optionally broken into 2, 4, or 8 pieces, each of which is addressable; these pieces may be DEVBSIZE, or some multiple of a DEVBSIZE unit. Large files consist of exclusively large data blocks. To avoid undue wasted disk space, the last data block of a small file is allocated as

only as many fragments of a large block as are necessary. The file sys-

tem format retains only a single pointer to such a fragment, which is a piece of a single large block that has been divided. The size of such a fragment is determinable from information in the inode, using the

bbllkkssiizzee(fs, ip, lbn) macro.

The file system records space availability at the fragment level; to determine block availability, aligned fragments are examined. The root inode is the root of the file system. Inode 0 can't be used for normal purposes and historically bad blocks were linked to inode 1, thus the root inode is 2 (inode 1 is no longer used for this purpose, however numerous dump tapes make this assumption, so we are stuck with it).

The fsminfree element gives the minimum acceptable percentage of file

system blocks that may be free. If the freelist drops below this level

only the super-user may continue to allocate blocks. The fsminfree ele-

ment may be set to 0 if no reserve of free blocks is deemed necessary,

however severe performance degradations will be observed if the file sys-

tem is run at greater than 90% full; thus the default value of fsminfree

is 10%.

Empirically the best trade-off between block fragmentation and overall

disk utilization at a loading of 90% comes with a fragmentation of 8,

thus the default fragment size is an eighth of the block size.

The element fsoptim specifies whether the file system should try to min-

imize the time spent allocating blocks, or if it should attempt to mini-

mize the space fragmentation on the disk. If the value of fsminfree

(see above) is less than 10%, then the file system defaults to optimizing

for space to avoid running out of full sized blocks. If the value of

minfree is greater than or equal to 10%, fragmentation is unlikely to be

problematical, and the file system defaults to optimizing for time.

Cylinder group related limits: Each cylinder keeps track of the avail-

ability of blocks at different rotational positions, so that sequential blocks can be laid out with minimum rotational latency. With the default of 8 distinguished rotational positions, the resolution of the summary information is 2ms for a typical 3600 rpm drive.

The element fsrotdelay gives the minimum number of milliseconds to ini-

tiate another disk transfer on the same cylinder. It is used in deter-

mining the rotationally optimal layout for disk blocks within a file; the

default value for fsrotdelay is 2ms.

Each file system has a statically allocated number of inodes. An inode is allocated for each NBPI bytes of disk space. The inode allocation strategy is extremely conservative. MINBSIZE is the smallest allowable block size. With a MINBSIZE of 4096

it is possible to create files of size 2^32 with only two levels of indi-

rection. MINBSIZE must be big enough to hold a cylinder group block, thus changes to (struct cg) must keep its size within MINBSIZE. Note

that super-blocks are never more than size SBSIZE.

The path name on which the file system is mounted is maintained in

fsfsmnt. MAXMNTLEN defines the amount of space allocated in the super-

block for this name. The limit on the amount of summary information per file system is defined by MAXCSBUFS. For a 4096 byte block size, it is currently parameterized for a maximum of two million cylinders. Per cylinder group information is summarized in blocks allocated from the first cylinder group's data blocks. These blocks are read in from

fscsaddr (size fscssize) in addition to the super-block.

NN..BB..:: sizeof (struct csum) must be a power of two in order for the

ffssccss() macro to work.

The Super-block for a file system: The size of the rotational layout

tables is limited by the fact that the super-block is of size SBSIZE.

The size of these tables is inversely proportional to the block size of the file system. The size of the tables is increased when sector sizes are not powers of two, as this increases the number of cylinders included

before the rotational pattern repeats (fscpc). The size of the rota-

tional layout tables is derived from the number of bytes remaining in

(struct fs).

The number of blocks of data per cylinder group is limited because cylin-

der groups are at most one block. The inode and free block tables must fit into a single block after deducting space for the cylinder group structure (struct cg).

The Inode: The inode is the focus of all file activity in the file sys-

tem. There is a unique inode allocated for each active file, each cur-

rent directory, each mounted-on file, text file, and the root. An inode

is `named' by its device/i-number pair. For further information, see the

include file . HISTORY

A super-block structure named filsys appeared in Version 6 AT&T UNIX.

The file system described in this manual appeared in 4.2BSD. 4.2 Berkeley Distribution April 19, 1994 4.2 Berkeley Distribution




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™