Manual Pages for UNIX Darwin command on man fd
MyWebUniversity

Manual Pages for UNIX Darwin command on man fd

FD(4) BSD Kernel Interfaces Manual FD(4)

NAME

ffdd, ssttddiinn, ssttddoouutt, ssttddeerrrr - file descriptor files

DESCRIPTION

The files /dev/fd/0 through /dev/fd/# refer to file descriptors which can

be accessed through the file system. If the file descriptor is open and the mode the file is being opened with is a subset of the mode of the existing descriptor, the call:

fd = open("/dev/fd/0", mode);

and the call:

fd = fcntl(0, FDUPFD, 0);

are equivalent. Opening the files /dev/stdin, /dev/stdout and /dev/stderr is equivalent to the following calls:

fd = fcntl(STDINFILENO, FDUPFD, 0);

fd = fcntl(STDOUTFILENO, FDUPFD, 0);

fd = fcntl(STDERRFILENO, FDUPFD, 0);

Flags to the open(2) call other than ORDONLY, OWRONLY and ORDWR are ignored. FILES

/dev/fd/#

/dev/stdin /dev/stdout /dev/stderr

SEE ALSO

tty(4) BSD June 9, 1993 BSD




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™