Manual Pages for UNIX Darwin command on man copy
MyWebUniversity

Manual Pages for UNIX Darwin command on man copy

COPY(9) BSD Kernel Developer's Manual COPY(9)

NAME

ccooppyy, ccooppyyiinn, ccooppyyoouutt, ccooppyyssttrr, ccooppyyiinnssttrr - kernel copy functions

SYNOPSIS

##iinncclluuddee <>

##iinncclluuddee <>

int ccooppyyiinn(const void *uaddr, void *kaddr, sizet len); int ccooppyyoouutt(const void *kaddr, void *uaddr, sizet len); int ccooppyyssttrr(const void *kfaddr, void *kdaddr, sizet len, sizet *done); int ccooppyyiinnssttrr(const void *uaddr, void *kaddr, sizet len, sizet *done);

DESCRIPTION

The ccooppyy functions are designed to copy contiguous data from one address

to another. All but ccooppyyssttrr() copy data from user-space to kernel-space

or vice-versa.

The ccooppyy routines provide the following functionality:

ccooppyyiinn() Copies len bytes of data from the user-space address uaddr

to the kernel-space address kaddr.

ccooppyyoouutt() Copies len bytes of data from the kernel-space address

kaddr to the user-space address uaddr.

ccooppyyssttrr() Copies a NUL-terminated string, at most len bytes long,

from kernel-space address kfaddr to kernel-space address

kdaddr. The number of bytes actually copied, including the terminating NUL, is returned in *done.

ccooppyyiinnssttrr() Copies a NUL-terminated string, at most len bytes long,

from user-space address uaddr to kernel-space address

kaddr. The number of bytes actually copied, including the terminating NUL, is returned in *done.

RETURN VALUES

The ccooppyy functions return 0 on success or EFAULT if a bad address is encountered. In addition, the ccooppyyssttrr(), and ccooppyyiinnssttrr() functions

return ENAMETOOLONG if the string is longer than len bytes.

SEE ALSO

fetch(9), store(9) BSD January 7, 1996 BSD




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™